Debian libmpg123 fix

From ShoutIRC RadioBot Wiki
Jump to: navigation, search

Some versions of Debian (and since it's based on Debian, Ubuntu) have old versions of libmpg123 that crash when you try to decode an MP3.
To fix it, su to root and do this:

apt-get remove libmpg123-0
cd ~
wget http://www.shoutirc.com/dl/mpg123.tar.bz2
cd mpg123-1.13.4
./configure --prefix=/usr
make
make install

Personal tools